Home » Mephisto Meisterschach » Mephisto Meisterschach – Windows Manual – English

Mephisto Meisterschach – Windows Manual – English

Details
Type
Manual
Platform
Windows
Language
English
Size
395.28 KB
Filename
mephisto-meisterschach_win_manual_en_wn7.pdf
View manual text
Mephisto

Online Help

By Dr. C. Donninger, T. Mally, A. Mader

This manual was produced using Doc-To-Help®, by WexTech Systems, Inc.

WexTech Systems, Inc.
310 Madison Avenue, Suite 905
New York, NY 10017
+1 (212) 949-9595

Contents
Chapter 1

1

Glossary of Terms

3

Index

5

Mephisto Online Help

Contents • i

How to...

Make moves
Click with the left mouse key on the square where the piece to be moved
is located (the square will be highlighted). Then click on the destination
square.

Castling
Pawn promotion

En passant

Special moves
The user only enters the king move, the rook move is automatically
executed by the program.
When the user moves a pawn to the opponent's back rank, the program
will open a window offering promotion to queen, rook, bishop or knight.
The user selects the desired piece type either by clicking on the desired
entry or by pressing the corresponding letter key.
When capturing en passant, the user only executes his pawn move; the
captured pawn is automatically removed by the program.

Take back moves
The arrow to the left of the Start/Stop button serves to retract moves:
o Clicking on this arrow with the left mouse key will take back the last
move played on the board.
Shortcut:

PageUp

o Clicking on this arrow with the right mouse key will take back the last
five moves played by both sides.
Shortcut:

Ctrl+PageUp

Play moves forward
The arrow to the right of the Start/Stop button serves to play forward
moves that have previously been retracted:
o Clicking on this arrow with the left mouse key will play forward the last
move that was taken back.
Shortcut:

PageDown

o Clicking on this arrow with the right mouse key will play forward the last
five moves by both sides that were taken back.

Mephisto Online Help

How to... • 1

Shortcut:

Ctrl+PageDown

Force moves
The command button labeled Start/Stop serves a double purpose:
o While the program is calculating: Clicking on the Start/Stop button
will cause the program to terminate its calculations and execute the best
move found so far on the board.
o When the program is not calculating: Clicking on the Start/Stop
button will cause the program to start calculating the next move for the
side that has the move (i.e. to switch colors).
Both functions may also be activated by means of the shortcut
Ctrl+Space.

2 • How to...

Mephisto Online Help

Commands

Menu File
This menu contains the following commands:
New Game
Exit

The program starts a new game.
Exits from Mephisto Meisterschach.

New Game (Menu File)
Causes the program to start a new game (after asking for confirmation),
i.e. to return the pieces to their initial locations. The program
automatically switches to Mephisto-Player mode, the current time
controls remain in effect.
Shortcut

Ctrl+N

Exit (Menu File)
Use this command to end your Mephisto Meisterschach session. You
can also use the Close command on the Control menu. Mephisto
prompts you to save the last game in the current database.
Shortcut
Alt+F4
or double-click Mephisto’s Control menu button with the mouse.

Menu Level
This menu contains the following commands:
Time/Move
User defined
Depth
Blitz
Infinite

The user can set the average time per move to a couple of given values.
The user can set the average time per move separately for White and for
Black.
The user can set a fixed search depth (in half moves).
The user can set the total time per game separately for White and for
Black.
The program analyzes without a time limit.

Time/Move (Menu Level)
5 Sec/Move

Mephisto Online Help

The user can set the average time per move to one of the following
values.
Average time per move is 5 seconds.

Commands • 3

10 Sec/Move
15 Sec/Move
30 Sec/Move
1 Min/Move
3 Min/Move

Average time per move is 10 seconds.
Average time per move is 15 seconds.
Average time per move is 30 seconds.
Average time per move is 1 minute.
Average time per move is 3 minutes.

5 Sec/Move (Menu Level / Time/Move)
Sets the average time per move to 5 seconds.

10 Sec/Move (Menu Level / Time/Move)
Sets the average time per move to 10econds.

15 Sec/Move (Menu Level / Time/Move)
Sets the average time per move to 15 seconds.

30 Sec/Move (Menu Level / Time/Move)
Sets the average time per move to 30 seconds.

1 Min/Move (Menu Level / Time/Move)
Sets the average time per move to 1 minute.

3 Min/Move (Menu Level / Time/Move)
Sets the average time per move to 3 minutes.

User defined (Menu Level)
Displays an input window allowing the user to enter the average time
per move (in seconds) for White and Black, respectively.

Depth (Menu Level)
Displays an input window allowing the user to enter the search depth (in
half moves) for the program's analysis of the current position.
Please note that the program uses a flexible search method and that the
actual search depth reached in certain tactical lines may exceed the
nominal depth set here quite considerably.

Blitz (Menu Level)
Displays an input window allowing the user to enter the total time per
game (in minutes) for White and Black, respectively. All the moves in the
game must be made before this total time runs out.

Infinite (Menu Level)
Set to this level, the program will analyze the current position without any
time limit, but will not execute any moves on its own. Clicking on the
Start/Stop button (or using the Ctrl+Space shortcut) will cause the
program to play the best move found so far on the board.

Menu Board
This menu contains the following commands:
Edit Position
Go To Move

4 • Commands

Allows the current position to be changed or a new position to be set up.
Jumps to the position preceding the white move with the number entered

Mephisto Online Help

here.

Edit Position (Menu Board)
After activation of this menu item, the program switches to the Edit
Position screen. It has its own menu bar and a display of the six piece
types to the bottom of the board. The currently active piece type is
highlighted.
Shortcut

Ctrl+E

Activate menu item Clear Board if you want to set up a completely new
position. The program will then remove all the pieces from the board.
Setting up pieces: Click on one of the piece types. This type is now
highlighted. You may also select the piece type via the menu bar, either
by clicking on the corresponding menu item (king, queen, rook, bishop,
knight, pawn) or by pressing ALT together with the corresponding letter
key. You may select the next piece type by pressing the space bar.
Move the mouse pointer to the desired square and click on it with the left
mouse key; a white piece of the selected type will appear on that square.
Move the mouse pointer to the desired square and click on it with the
right mouse key, a black piece of the selected type will appear on that
square.
To remove a piece from the board, click with the left or the right mouse
key on the square occupied by that piece.

Side To Move
Castling rights

Move number

When you are satisfied that the position is set up correctly, activate menu
item OK. A window labeled Initial state will appear, allowing you to enter
the following information:
White or Black
Here the user can determine whether kingside/queenside castling is to
be permitted for White and Black, respectively (change settings by
clicking on the corresponding box). The program will propose reasonable
settings, based on an examination of the position that has been set up.
The move count will begin with the number entered here.
After activation of OK, the program will accept the input and return to the
main screen.

OK
Cancel
Clear Board
Turn
King
Queen
Rook
Bishop
Knight
Pawn

The Edit Position menu bar contains the following commands:
Finishes the set-up process.
Discards all changes and returns to the main screen.
Removes all the pieces from the board.
Turns the board around by 180 degrees.
Selects the king as the currently active piece type.
Selects the queen as the currently active piece type.
Selects the rook as the currently active piece type.
Selects the bishop as the currently active piece type.
Selects the knight as the currently active piece type.
Selects the pawn as the currently active piece type.

OK (Menu Board / Edit Position)
Finishes the set-up process and displays the Initial State window before
returning to the main screen.

Mephisto Online Help

Commands • 5

Cancel (Menu Board / Edit Position)
Discards all changes to the current position and returns to the main
screen.

Clear Board (Menu Board / Edit Position)
Removes all the pieces from the board (allowing a new position to be set
up).

Turn (Menu Board / Edit Position)
Turns the board around by 180 degrees (as in the Board/2D Turn
command).

King (Menu Board / Edit Position)
Selects the king as the currently active piece type. Click with the left
mouse key on the desired square to set up a white king. Click with the
right mouse key on the desired square to set up a black king.

Queen (Menu Board / Edit Position)
Selects the queen as the currently active piece type. Click with the left
mouse key on the desired square to set up a white queen. Click with the
right mouse key on the desired square to set up a black queen.

Rook (Menu Board / Edit Position)
Selects the rook as the currently active piece type. Click with the left
mouse key on the desired square to set up a white rook. Click with the
right mouse key on the desired square to set up a black rook.

Bishop (Menu Board / Edit Position)
Selects the bishop as the currently active piece type. Click with the left
mouse key on the desired square to set up a white bishop. Click with the
right mouse key on the desired square to set up a black bishop.

Knight (Menu Board / Edit Position)
Selects the knight as the currently active piece type. Click with the left
mouse key on the desired square to set up a white knight. Click with the
right mouse key on the desired square to set up a black knight.

Pawn (Menu Board / Edit Position)
Selects the pawn as the currently active piece type. Click with the left
mouse key on the desired square to set up a white pawn. Click with the
right mouse key on the desired square to set up a black pawn.

Go To Move (Menu Board)
Displays an input window allowing the user to enter a number. The
program then jumps to the position immediately preceding the white
move with that number.
Entering 0 will cause the program to jump to the end of the game.
Shortcut

Ctrl+G

Menu View
This menu contains the following commands:
2D

6 • Commands

Switches the board display to 2D mode.

Mephisto Online Help

3D
Turn
Coordinates

Switches the board display to 3D mode.
Turns the board around by 180 degrees.
Determines whether the coordinates for the ranks and files are to be
displayed along the edges of the board.

2D (Menu View)
Switches the board display to 2D mode.

3D (Menu View)
Switches the board display to 3D mode.

Turn (Menu View)
Turns the board around by 180 degrees (e.g. to allow the user to play
with the black pieces from the bottom of the board).

Coordinates (Menu View)
When this option is set to ON, the coordinates for the ranks and files are
displayed along the left and upper edges of the board.

Menu Play-Mode
This menu contains the following commands:
Mephisto-Player
Tournament
Player-Player
Analysis
Next Best
Autoplay

The user plays a game against the program.
Mephisto simulates a game under tournament conditions.
The user enters the moves for both sides.
The program analyzes the position without a time limit.
The program excludes the best move so far from its analysis and
calculates the next best move (in Analysis Mode only).
The program plays a game against itself.
The current play mode is displayed above the Start/Stop field. Click on
this field to change the play mode in the following order:
Mephisto-Player => Player-Player => Analysis => Mephisto-Player etc.

Mephisto-Player (Menu Play-Mode)
This is the normal playing mode, where the program calculates and
executes the moves for one side and the user enters the moves for the
other side. When it is the user's turn to move, he/she can switch sides by
clicking on the Start/Stop button, which will make the program start
calculating the next move.
Shortcut

Ctrl+M

Tournament (Menu Play-Mode)
In this mode, Mephisto always uses the best opening book. You cannot
take back moves and the information is automatically turned off.
Shortcut

Mephisto Online Help

Ctrl+T

Commands • 7

Player-Player (Menu Play-Mode)
In this mode the user enters the moves for both sides. The program only
checks the moves for their legality. This mode is particularly well suited to
the replaying of stored games; that is why it is automatically activated
after a game has been loaded from a database.
Shortcut

Ctrl+P

Analysis (Menu Play-Mode)
In this mode the program will keep analyzing the current position without
any time limit and display the relevant information, but without executing
any moves on its own. The user is free to make moves on the board, take
them back and play them forward again. Clicking on the Start/Stop
button (or using the Ctrl+M shortcut) will cause the program to execute
the best move found so far on the board.
Shortcut

Ctrl+A

Next Best (Menu Play-Mode)
This function is available in Analysis mode only. It will cause the program
to exclude the best move found so far from its further analysis and start
searching for the "next best" move in the current position. The function
may be used repeatedly, allowing the user to search for the two, three,
four... best moves in a given position.
Shortcut

Ctrl+X

Autoplay (Menu Play-Mode)
Starts the program playing a game against itself (with the current time
controls). To stop automatic play, switch to a different play mode (e.g. by
activating Mephisto-Player mode by means of the Ctrl+M shortcut).
Shortcut

Ctrl+U

Menu Book
This menu contains the following commands:
Random
Show-Moves

Determines whether opening moves are to be chosen at random.
Determines whether the moves from the current opening library are to be
displayed in the information window.

Random (Menu Book)
Determines whether the program's choice of opening moves should be
made randomly or not. If the setting is OFF, the program will always play
one of the moves with the highest priority from its book; if the setting is
ON, it will sometimes choose weaker moves, thereby producing more
variation in the games played.

Show-Moves (Menu Book)
Determines whether the moves available from the current opening book
are to be displayed in the information window to the right of the board. If
the setting is ON (i.e. the moves are displayed), the desired opening

8 • Commands

Mephisto Online Help

move can be carried out on the board by clicking on the corresponding
entry.

Menu Options
This menu contains the following commands:
Information
Hint Move
Sound
Move Animation
Style
Language
Players’ Names
Handicap Mephisto

Determines the extent of the information to be displayed in the analysis
window.
Determines whether the program's hint move is to be displayed.
Determines whether the program's moves are to be accompanied by
sounds.
Determines whether the ‘from’ and the ‘to’-square are to be animated
before Mehisto moves.
Offers a choice between several playing styles.
Selects the language to be used for the user interface.
Allows the user to enter the names of the players with White and Black,
respectively.
The program deliberately commits tactical errors.

Information (Menu Options)
Off
Normal
Extra

Allows the user to determine the extent of the information to be displayed
in the analysis window below the chessboard.
No information.
Two lines of information about the program’s calculations.
In addition to the normal display, two extra lines of information about the
program's "permanent brain" feature are displayed. (This expression
refers to the program's ability to go on calculating even when it is the
opponent's turn to move.)

Hint Move (Menu Options)
When this option is set to ON, the program will display the words "Hint
Move" and the next move it expects from its opponent in the space
between the clock and information windows. To execute this move, you
may either press the Insert key or click on the space where the hint move
is displayed.

Sound (Menu Options)
When this option is set to ON, every move made on the board will be
accompanied by certain sounds; these differ depending on the type of the
move (e.g. whether it is a normal move, a capture or a check).

Move Animation (Menu Options)
When this option is set to ON, the program will indicate the "from" and
"to" squares of its moves by making them blink repeatedly; otherwise, the
pieces will jump to their new squares immediately.

Style (Menu Options)
Standard
Aggressive
Defensive

Mephisto Online Help

The default setting.
With this setting, the program will do its best to advance its pieces into
the opponent's half of the board.
With this setting, the program will try to prevent the opponent's pieces

Commands • 9

Tactical

from intruding into its own camp at all costs.
This is an option that can be added to any of the three styles discussed
above. When it is set to ON, the program will examine tactical lines with
particular thoroughness. This has a positive effect on its combinational
capabilities but may slow down and thereby weaken the program in
"normal" positions.

Language (Menu Options)
Here the user can select the language (English or German) to be used by
the user interface (i.e. menus, help texts etc.).

Players’ Names (Menu Options)
Displays an input window allowing the user to enter the names of the
player with the white and the black pieces, respectively. Default names
are ‘Mephisto’ for the program's side and ‘White’ or ‘Black’ for the user's
side. In the case of a game loaded from a database, the display is
determined by the information stored in the database.

Handicap Mephisto (Menu Options)
This mode is similar to the normal Mephisto-Player mode; the only
difference is that in this mode the program will deliberately commit
tactical errors to give unskilled players a chance to train their eye for
combinations.
When this menu item is activated, there appears an input window which
permits the user to set the "error rate" on a scale by means of a sliding
marker. A total of 50 positions is available in the range from "low" to
"high".
(a) Move the mouse pointer to the sliding marker, keep the left mouse
key pressed down and "drag" the marker to the desired position.
(b) Pressing a cursor key will move the marker one position to the
left/right. Pressing the PageUp key will move the marker ten positions to
the left; pressing the PageDown key will move it ten positions to the right.

Menu Database
This menu contains the following commands:
Save Game
Load Game
Change Database
New Database
Import PGN
Export PGN
Remove Database
Database Size

Saves the current game in the currently open database.
Allows the currently open database to be searched for games according
to certain criteria; the games found in this way can then be loaded.
Opens an existing database.
Generates and opens a new database.
Converts a game collection in PGN format into a Mephisto database.
Converts a Mephisto database into a game collection in PGN format.
Deletes a complete database.
Displays the number of games stored in the current database.

Save Game (Menu Database)
Displays the number of games stored in the current database. The game
is always added to the end of the database file.

10 • Commands

Mephisto Online Help

After this menu item is activated, there appears an input window allowing
the user to enter information about the game to be saved (the "game
tag"). To finish the procedure, confirm the Save Game command by
activating OK or use Cancel to exit from the input window without saving
the game.

Load Game (Menu Database)
Reads in games selected by various criteria from the currently open
database. During the reading-in process, there appears a window
informing the user about the progress being made. You may activate the
Stop button to interrupt this process (then only the games read up to that
point will be available for loading). Cancel breaks off the reading-in
process and returns to the main screen.
The data of all the games read are presented in a list. The user may
navigate through this list by means of the vertical sliding bar or with the
cursor and Page Up/Down keys. The desired game may be marked by
clicking on it and loaded by activating the Load button (or by a double
click on the corresponding game entry); the program then returns to the
main screen. Cancel returns to the main screen without loading any
game.
In order to simplify the handling of game lists in the case of large
databases, games are always listed in blocks of 100 items. In the list
window, the Found field informs the user about the total number of
games read in, while the figures in the Range field show which part of the
complete list is currently accessible in the list window. Which part of the
database is listed in the window can be determined by the user by means
of the following command buttons:
Top
Bottom
Up
Down
Go To
Delete

List All
Last Found
Last Saved
Search Text
Game Tag

Jumps to the first block of the game list.
Jumps to the last block of the game list.
Jumps to the preceding block of the game list.
Jumps to the following block of the game list.
Jumps to the block that starts with he number appearing in the input field
above this command button.
Removes the marked game from the database (after asking for
confirmation).
The Load Game submenu contains the following commands:
Reads in all the games stored in the currently active database.
Displays a list of the games found during the last search.
Displays the last game saved in a database.
Reads in games from the current database containing a certain piece of
text.
Reads in games from the current database containing matching game
information.

List All (Menu Database / Load Game)
Reads in all the games from the current database.

Last Found (Menu Database / Load Game)
Displays a list of the games found in the current database the last time a
search was carried out. This command is mainly used when you have
already selected several games from a database and now want to load
one game after the other.
Shortcut

Mephisto Online Help

Ctrl+L

Commands • 11

Last Saved (Menu Database / Load Game)
Displays the last game saved (even if the game was saved in a database
other than the one currently open). If you saved a game the last time you
left the program, this function will enable you to re-load that game
immediately.
Shortcut

Ctrl+S

Search Text (Menu Database / Load Game)
Displays an input window allowing the user to enter a piece of text (not
necessarily a whole word) that is to be searched for in the game
information of the current database. No distinction is made between
upper and lower case. After activation of OK, all games from the current
database that contain matching text are read in.

Game Tag (Menu Database / Load Game)
Displays an input window similar to the one associated with the Save
Game command, allowing the user to input game information to be
searched for. If the Player Color option is set to Significant, only games
where the players' names for White and Black are correctly matched with
their respective colors will be read in; if the setting is Not Significant,
games where the colors were reversed will also be found. After activation
of OK, all games from the current database that contain matching game
information will be read in.

Change Database (Menu Database)
Allows a database to be selected from a list. After activation of OK, this
database will be made the currently open database.

New Database (Menu Database)
Displays an input window that allows the name of the new database to be
entered. After activation of OK, the program will generate a new
database of that name and make it the currently open database. A
warning is issued if a database of that name already exists.

Import PGN (Menu Database)
Allows game collections in PGN format to be converted to the Mephisto
format.
First the typical Windows95 file search window is displayed. Here you
must find and mark the PGN file to be converted (the "source file"; finish
with OK).
Next a window is displayed allowing a name for the Mephisto database to
be entered (or an already existing name to be marked in a list). This is
the "target file" into which the games are to be written in converted form.
The program will then open a new database of that name or open an
existing database for the transfer of data. (If the database already exists,
the new games will be added to it, existing games will be retained.)
Activation of OK will start the conversion process; an information window
displays a report on the progress being made. When the work is finished,
the Mephisto database will remain open, so it can be accessed
immediately (e.g. for one of the Load Game options).

12 • Commands

Mephisto Online Help

Export PGN (Menu Database)
Allows a Mephisto database to be converted to the PGN format.
First there appears a window where you can select a Mephisto
database from a list of all such databases. (This is the "source file"; finish
with OK).
Then there appears the typical Windows95 file search window, where
you can enter the name for the PGN file (or mark the name of an already
existing file) that the converted games are to be written to (the "target
file"). The program will then open a new PGN file of that name or open an
existing file for the transfer of data. (If the PGN file already exists, the
new games will be added to it, existing games will be retained.)
Activation of OK will start the conversion process; an information window
displays a report on the progress being made.

Remove Database (Menu Database)
Displays a list from which a database may be selected. After activation of
OK, the program first asks for confirmation and will then delete the
selected database.

Database Size (Menu Database)
Displays a window with information about the number of games stored in
the current database.

Menu ‘?’
This menu contains the following commands:
Info about Mephisto
Help Topics

Displays information about the copyright and the persons involved in the
making of Mephisto Meisterschach.
Displays a list of topics available in Mephisto’s help feature.

Info about Mephisto (Menu ‘?’)
Here you will find information about the copyright and the names of the
persons involved in the making of Mephisto Meisterschach.

Help Topics (Menu ‘?’)
Displays the Windows95 help topics window, which provides a list of all
menu items of Mephisto Meisterschach and of additional information
about the handling of the program. A double click on one of the entries
will take you to the help screen covering that topic.

Mephisto Online Help

Commands • 13

Glossar

Mephisto Online Help

Glossar • 15

Index

Error! No index entries found.

Mephisto Online Help

Index • 17

Download PDF